I am getting the site can't be reached after hosting my site on cloudflare

I am getting this error when I am trying to access my site, I deployed it to Heroku and I changed the domain to a custom domain and used Cloudflare to get CNAME to use to my domain name provider.

Seems you have a DNS issue.

Site resolves and loads fine → sitemeer.com/#litorisdesign.rw

Try flushing your local DNS resolver or switch to another public resolver.

Thanks, Sandro, I’ve checked to make all requests from HTTP behaves as HTTPS, but when I visit HTTP the site loads fine but when I load it as HTTPS it can’t be reached

It loads on HTTPS equally fine - sitemeer.com/#https://litorisdesign.rw

The screenshot you posted is DNS related, not HTTPS related.

Can you post the output of these commands?

ping litorisdesign.rw
ping www.litorisdesign.rw
nslookup litorisdesign.rw
nslookup www.litorisdesign.rw

I run those commands in the CMD, not sure if it was where you wanted me to. FYI, the site is running smoothly now but I am nervous that it will crash again as it was running before too.

You are resolving the right addresses. Do you still get the same error?

Noh, the error is resolved now, but I haven’t changed anything. It just worked, that’s why I am still worried. but if it fails me again I will reach out to you. Thanks for the quick help

Will have been aforementioned DNS issue.

sorry, I didn’t understand that response

Meant this I am getting the site can't be reached after hosting my site on cloudflare - #2 by sandro

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.