I am getting problem with the HTTP calls,

I am getting problem with the HTTP calls, The API calling not working in my angular app with Proxy status enabled in DNS settings of dev subdomain

I have enabled Proxy status enabled from dns settings for subdomain - dev.

I am not getting api calling works in angular app? Any idea why its happening?

HTTPS calls not working on enable proxy status enabled.

The issue you’re facing might be related to a conflict between Cloudflare’s Proxy settings and your API calls. Cloudflare acts as a reverse proxy and sometimes it can interfere with API calls, especially when HTTPS is involved. To resolve this, you can follow these steps:

  1. Go to your Cloudflare Dashboard.
  2. Navigate to the DNS settings.
  3. Find the “dev” subdomain that you’re having problems with.
  4. Switch the Proxy status from “Proxied” to “DNS only”.

Remember this will expose your server’s IP address. If the issue persists, please inspect the error message from the API call for a more specific problem.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.