I am getting error 403 on almost every page of CloudFlare Dashboard

Hi, I’ve decided to start using Cloudflare after some years, but after login to my Cloudflare Dashboards I can’t manage my domains (403 | You don’t have permission to view this page.), can’t add new website and also getting same error at Manage Account page.

Here on the forum I see several similar posts. It was always quickly resolved. Can someone help us with this too?


I’m sorry to hear that you’re experiencing a 403 error on your Cloudflare Dashboard. Please try the following steps to resolve the issue:

  1. Clear your browser’s cache and cookies.
  2. Disable any browser extensions that might interfere with the dashboard (i.e., ad blockers, script blockers, privacy extensions, etc.).
  3. Try using a different browser or an incognito/private browsing window.
  4. Ensure that your Cloudflare account email address is verified. If it’s not, please check your email (including the spam folder) for a verification email from [email protected] and follow the instructions within the email to verify your account.
  5. If the issue persists after trying these steps, please contact Cloudflare support by submitting a request at https://dash.cloudflare.com/?to=/:account/support. Make sure you provide the necessary details (e.g., your account email address, domain names you can’t manage, and the exact error message).

The Cloudflare team will investigate the issue and assist you accordingly.

If you reach step 5 above, share the ticket number here, and we will make sure it is associated with this topic.


I tried everything you mentions, but didn’t work. I submitted ticket. [2765413](https://support.cloudflare.com/hc/requests/2765413)

Thanks. You should see a response here as well as on the ticket.

It looks like you confirmed that we fixed it in the ticket. Sorry that you had to deal with this and glad that things are working.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.