I am facing this error:- net::ERR_SSL_PROTOCOL_ERROR

I am having trouble activating socket.io configuration for my node app.

Port 5002 isn’t supported:

You’ll have to change that port to one of CF’s supported HTTPS ports.

2 Likes

Thank you for the reply, i have read the doc you had provided, it seems that if we turn them off,i.e.make the domain a gray domain or turn off the proxy it should work but i have tried that, still it’s not working.

What is the issue? can you also share a detailed doc please. if possible.

Hi @A4U,

With the :grey: Cloudflare operates as DNS-only and it seems to be working perfectly according to my dig queries, so this is an issue on your end.

If it is related to socket.io, try Stack Overflow, as they recommend.

Okay thank you for the help.

1 Like