Hubspot email sending domain (Missing records)

Hi everyone, we are trying to connect our email sending domain from hubspot. However, its not verifying the records even though we added the data correctly and made sure to disable proxy.

Im wondering if this is related to domain wide cname flattening set to disable which hubspot instructed. But i cant find an option to do this in Cloudflare. Any advice on how to fix this? TIA


Could you maybe share the information that you censored in your screenshot, your domain, and also test your email with ?

You can find the option for CNAME flattening here, it is only available on paid plans and disabled by default (select your account and domain):

1 Like

These are the cname records from hubspot. For some reason, it has an error “missing records”.

If we subscribe to a paid plan, can we disable the domain wide CNAME flattening? will it have a negative effect on the other domain record we added?

As I said previously, it is disabled by default. If you subscribe to a paid plan, you can enable it (not what you want).

And again, please share the DNS records you are supposed to create and your domain, but don’t censor anything. There is nothing private about these DNS records.

1 Like

I see. Here are the records as requested. Thanks

That looks like you did everything correctly to me, I can find the records as they are in the screenshot, and there aren’t any other obvious problems like DNSSEC.

dig +short

dig +short

Could you inquire with Hubspot what they think the problem is?


Ok, I’ve just checked again and actually, there does seem to be a problem, though I have no idea what it is.

For some reason, Cloudflare’s public DNS resolver does not resolve your domain, though other resolvers are fine:

Local resolver:
dig +short

dig +short @

dig +short @

Maybe someone else has an idea?

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.