HTTPS Works on some computers but not others?


#1

Hello all,

I’ve been struggling for the past 3/4 hours trying to figure out this HTTPS stuff… I got mad and decided to check it out on my mobile device and it was working… I tried on my xbox one, it worked, my laptop, it wokred… But apparently on my desktop it is not working an I get “Your connection is not private” on firefox, chrome and edge.

I am using xampp on a local computer to just build and test things out as a personal project and this is really bugging me. My friend went on it as well and it gave him the same error so I’m assuming it has something to do with if you visited the site prior to me adding the https? I cleared the cache, history, cookies, everything and it is still not working…

Can someone please help me?


Why isn't my SSL lock showing in the browser?
#2

EDIT: The certificate is self signed and did the whole thing with cloudflare to get it working yet the certificate itself in my xampp folder says “Windows does not have enough information to verify this certificate”.


#3

Of you have added your domain recently to CloudFlare it could take some time for the new DNS Records to be propagated. Depending on TTL and DNS caches.

If you’re still seeing your own self-signed certificate, check if the record is set to :orange: and SSL is set to “Full”.

You can also create a client cert from your CloudFlare that can be installed on your servers. it should contain the certificate chain as well. Ensure that xampp knows this chain. I am not sure if it uses the Windows certificate store.

Since xampp is intended for development, secure access to your xampp installation


#4

Yes SSL is set to full, ive had cloudflare set up for months now and everything on here is set properly. I used the website whynopadlock and sslshopper and they both say https is fine and working,…

I clearled the cache in my brownsers and on cloudflare… So i dont think this would be a cache error? But then again my other laptop hasent been on the site before today… If thats the case why isnt clearing my cache working. I also did a dns flush but that didnt help.


#5

This still isnt fixed if anyone knows or had this happen before. I waited 48 hours so see if it was a isp cache issue but clearly its not. Anyone who accessed my site before i enabled https cant get https but instead its “unsecure” but any new visitors are fine… This is really annoying me, its been 3/4 days ive been working on this


#6

That’s an interesting tidbit. Only return visitors are experiencing the problem.

I would look at the following using Chrome Dev Tools:

  1. The Security tab to take a look at the certificate (I think you’ve done this)
  2. The Network tab to check the IP address of the host you’re connecting to. It should match the IP address you see on your Laptop’s Chrome Dev Tools.

My theory is it’s still a funky DNS issue. Try these:
https://documentation.cpanel.net/display/CKB/How+To+Clear+Your+DNS+Cache

For kicks, I’d also change the DNS server the Desktop uses:
https://1.1.1.1/#setup-instructions

If all that fails, would you mind posting your domain name?


#7

Thank you for the reply,

I tried those and its still like this lol. Ill do a quick runthrough. My site domain is from freenom and then i use cloudflare. Somewhere something is bad and not clearing cache or updating previous members

Forum is https://www.clubraven.tk

As mentioned its only a personal project im working on with a few people until everythings good and well get a host afterwards.


#8

Im just posting in here since my post isnt getting any ideas.

My site is https on every device that hasnt accessed my site prior to me adding https. I even tried virtualbox on my desktop that cant access it and it worked on there so it has to be some kind of cache issue or something…

Whynopadlock says everything is good as well, i cleared my browsers cache, cleared cloudflare cache, did a dns flush and still cant access https on my desktop… Its been over 48 hours nowsince i enabled it so i really dont know whats going on but its driving me crazy.


#9

Double-posting makes it difficult for others to keep track of your responses. Bumping this back over to original thread.


#10

I also have a Freenom .tk domain and haven’t run across this. I checked yours, and it’s working. I’m sure that doesn’t surprise you since I’ve never visited it before.

What I do notice is the Cloudflare certificate was renewed on April 8th (a week ago). This makes me think you have a stored certificate. Maybe someone proficient with Windows knows how to clear this. Within Chrome, mine directs me to my MacOS Keychain/Certificate manage. From Firefox, it seems to have its own certificate manager.

Can you also go to Cloudflare’s Cache settings and Purge Everything? There’s an off chance, though I doubt it, that something’s stored in Cloudflare’s cache.

Just to confirm, when you use Chrome Dev Tools and check the Network connection, you’re getting the same IP address on your Desktop (broken connection) as the Laptop (working connection)?


#11

The certificate was make by me, I deleted it and self signed one with cmd. I then copied the request file into cloudflares “Origin Certificates” and replaced the certificate and key with what was generated.

As for the chrome dev part, I’m not very sure what you mean by this, im in inspect elements in the Network tab and they both look the same?

I just purged the cache on cloudflare a second time and still nothing.


#12

So I noticed in the Response header on my desktop it says “Server: Apache/2.4.27 (Win32) OpenSSL/1.0.2l PHP/7.1.9”

And my laptop says “server: cloudflare”.

Also the remote address on my desktop says 127.0.0.1:80 and my laptop has a macaddress:443

Even if the local ip thing is an issue that’s not the reason others are having the same error


#13

That April 8th certificate is the one on Cloudflare’s proxy server.

I’ve always had Cloudflare generate the private key and CSR and it’s worked well for me. I believe if your local certificate were an issue, a different error would pop up.

For your desktop, you probably added a host entry for local testing. Give this a try:

Hopefully, you’ll now be able to reach your site. Then we move on to tracking down your other users’ problems. If you’re in contact with any of them, have them go through the steps you did to verify which site they’re connecting to.


#14

Oh wow… It’s because I had
127.0.0.1 www.clubraven.tk
127.0.0.1 clubraven.tk
In my host file. When I first started using Xampp years ago I was told to always put that in the host file so that others can connect to it. Now it works with HTTPS


#15

This topic was automatically closed after 14 days. New replies are no longer allowed.