HTTPS works for 1hour, then doesn't work [Solved]


#1

I checked on Youtube how to add HTTPS on my personnal wordpress site. I created an account, I changed my DNS, I installed the plugin for Cloudflare, I changed the SSL to flexible… all perfect.

That worked for 1 hour, and then, for no reasons, not work anymore… the HTTP is ok but not the HTTPS.

Why ? It is a DNS problem ? I mean, maybe I just have to wait… but why did it work like 2hours ago and not now ?

*Sorry for my english, I’m from France btw


#2

It still could be DNS. When I move a domain, I see the IP address change back and forth for a day or two.
You can check here:
https://www.whatsmydns.net/


#3

All in green… I don’t know where is the problem :confused:


#4

It’s good for me. I still think it’s DNS. Sometimes my local DNS takes a while.

You can also use Chrome Dev tools to check the Response Headers which will show you the IP address. You should also see some Cloudflare CF headers if you’re going through Cloudflare.

If it’s DNS, then you can set your computer to use Google’s DNS at 8.8.8.8 and 8.8.4.4


#6

Last hour it worked ! I was in HTTPS, no problems ! And now, I didn’t do anything and the problem is back… I don’t think its the DNS 'cause since this morning the problem appear and then disappear…

*Edit: I’m through Cloudflare, I just checked once again…


#7

Edit: fixed.


#8

This topic was automatically closed after 14 days. New replies are no longer allowed.