HTTPS vs HTTP

Hi,

I just successfully installed the SSL certificates on my site and its sub-site.

However, since both sites are “http” and not “https” the certificate does not show…

Unless i retype https:// and then the urls.

I have the free SSL certificates. And they are set to ‘flexible’ - and, obviously ‘active’.

Is there a quick way to make everything ‘https’ instead of’ ‘http’?

I hope that I don’t have to re-code the entire sites!

The sites are housed on GoDaddy’s Linux Delux Hosting Plan.

Thanks!

Laraine

Hello @laraine_moore

I would recommend try below two steps.

  • Login to Cloudflare > Select Account > Select domain > go to SSL/TLS menu > Edge Certificate > Enable Automatic HTTPS

  • Scroll down, enable Automatic HTTPS Rewrites

I hope this helps.

Thanks, Gulshan!

I did remember seeing that somewhere.

Yet, I’m grateful that you told me that it is okay to enable the automatic HTTPS rewrites!

That would have been a ridiculous task for me to do that manually, lol!

I will try now!

All the Best! :slight_smile:

Laraine

Yes, it’s completely safe to enable Automatic HTTPS rewrite, it change all HTTP instance to HTTPS in the HTML page.

You’re welcome! :slight_smile:

Hi Again, Gulshan,

I logged in and saw that the automatic HTTPS Rewrites were already enabled.

And I see that the lock icon appears in the Opera Browser when I just type the site name.

Yet on MS Edge and Chrome the site is not secure. (I’ve only checked the subsite).

Weird…

Maybe it’s just taking some time to upload, since I did this a few hours ago?

Can I have site URL so I can try to repro the issue at my end? That would be helpful in providing quick assistance. Thanks

Thanks for helping with this:

The parent site is: www.larainemooredesign.com

The subsite is: www.SpiritsInSpacesuits.com

(Both sites are the SAME site.)

Can you please confirm if you have turned on “always use https” ?

I will double-check right now… tks

That was off.

I just turned on “always use HTTPS”…

Hope that helps…

Thanks!!! :slight_smile:

1 Like

It’s working now in Opera, Chrome and Edge.

I did not clear the browser cache.

Do u see it working on your end?

Thanks!!! :slight_smile:

I can confirm now that as expected, I am able to see HTTPS with green lock. Your site is secured with SSL Cert.

image

image

Thank you Gulshan for fixing all this…

and also for teaching me!

Have a wonderful holiday season.

Best,

Laraine

Same for you :slight_smile:

Thanks for the best wishes!

Welcome,

Take Care!

Bye! :slight_smile:

That should be the first thing to change. Flexible should not be picked and is insecure.

You need to make sure that you have a proper certificate on your server (right now your server is not configured at all for HTTPS) and then switch that to “Full strict”. “Full strict” is the only secure configuration.

This topic was automatically closed after 30 days. New replies are no longer allowed.