HTTPS vs HTTP, other issues from a newbie

Hello! I’m not super savvy so please bear with me. I am creating a website using Notion and I followed these instructions as seen on Fruitionsite.

I’m experiencing a handful of issues.

Most importantly, I successfully see my Notion-turned-website if I go to https:// my website URL, but if I go to http:// my website URL, I see a “Site not found” page by Dreamhost, my hosting service.

The other being that I’m receiving this message: Some of your DNS only records are exposing IPs that are proxied through Cloudflare. Make sure to proxy all A, AAAA, and CNAME records pointing to proxied records to avoid exposing your origin IP.

However I have no idea what needs to be done to fix it. One of the list items in the DNS only section has a triangle icon next to it, but when I click to expand, nothing appears about proxying. I don’t even know what proxying is.

I really appreciate any assistance. Thanks.

That’s opposite of what usually happens, but in SSL/TLS -> Edge Certificates, you can enable “Always Use HTTPS” and it will redirect before it gets to your site. “Automatic HTTPS Rewrites” farther down that page also worth enabling.

Thank you, I turned the “Always use HTTPS” on, and the other was already toggled on. But it seems to have not fixed the issue…

I cleared my 1hr browser history and when I refreshed a tab where my site was loading successfully, it said it was insecure and I had to click “advanced” to proceed. And then it did show my website successfully.

However if I open a new tab and type in emilyellis.design it still shows Site Not Found but now in the address bar it does show httpS://

So now I’m completely stumped why sometimes it works, and sometimes it doesn’t.

I’ve ALSO noticed that my email for that domain works in the dreamhost web client, but not through the email client on my iphone.

when I refreshed the DNS page in Cloudflare I see this message briefly before it resolves to the original message about my IP being exposed.

Thoughts?

At the moment, that domain is not using Cloudflare. It’s using GoDaddy name servers and served from a GoDaddy web server.

I’m not sure how that’s possible, I bought the domain through dreamhost and have never used GoDaddy.

Where do you see that?

If I look up the domain in dreamhost it shows the cloudflare nameservers I set it to

Maybe I typed it in wrong. My mistake.

Now that I’m typing it in correctly, it works without ‘www’. With www, it’s not so good, but can be fixed with a Page Rule:
Match: www.emilyellis.design/*
Setting: Forwarding URL (301) to https://emilyellis.design

Oh great, I got that to work! Thank you so so much.

Can you assist with the other errors I’m getting in Cloudflare? How do I fix my email, and IP privacy?

This topic was automatically closed after 30 days. New replies are no longer allowed.