HTTPS stop to work suddenly



One of my domains on CloudFlare went down suddenly during the past night with this error on Chrome: ERR_SSL_VERSION_OR_CIPHER_MISMATCH.

HTTP without SSL works normally but HTTPS doesn’t work anymore.

All my other domains on Cloudflare work properly with HTTPS.

On my account, it is written : Status - Active Certificate

I changed to Full SSL or Flexible SSL, it does not resolve the problem.
I bought a dedicated SSL certificate, it does not resolve the problem.
I deleted my domain on CloudFlare and added it again, it does not resolve the problem.

I pause my domain: Currently all HTTPS requests pass through Cloudflare and go directly to my hosting server.
But it is a temporary solution, I want to use CloudFare services.

How to make the CloudFlare SSL certificate working properly again?

Thanks for your support,



Have you tried turning on Always Use HTTPS on the Crypto tab when the site is not paused?


Unfortunately, it does not work.

But I have seen something strange.

My website was down on 5th October for HTTPS, it was the same date of the CloudFlare certificate renewal.

My domain ( is included in the certificate (

AND my domain ( is also included in the certificate ( renewed on 5th October, EXACTLY the date when my website was down for HTTPS with this error on Chrome: ERR_SSL_VERSION_OR_CIPHER_MISMATCH.

Same date for an unexpected second SSL certificate AND domain down for HTTPS, the duplication could be the reason…

How is it possible to “delete” my domain on those certificates?

I removed my domain from CloudFlare, but the certificates still include my domain.
I tried to remove and add again my domain on Cloudflare, I have still the HTTPS problem.

Thanks for your support,


This is happening on one of the sites I maintain. Suddenly all browsers are giving me ERR_SSL_VERSION_OR_CIPHER_MISMATCH error even though nothing has changed.

Oddly enough, if I try to get to this site via AT&T is comes up fine but via Comcast it gives the ERR_SSL_VERSION_OR_CIPHER_MISMATCH.


I am having the EXACT same issue as Leah above. PLEASE HELP.


There are already two other threads on this topic, so keep an eye on the one I referred to on…the other one. Hopefully these three threads will be solved in the one other thread:


I had the problem resolved with Cloudflare support but it took 2 weeks… IP mapping problem on Cloudflare servers. Now it s ok.


I have this problem just tonight.
Very unacceptable scenario.
My site was down for few hours until now.

I have to disable Cloudflare CDN for now to avoid similar issue on the future.


I’m experiencing the same issue. Intermittently getting the “ERR_SSL_VERSION_OR_CIPHER_MISMATCH” error on my sites. When I update my DNS to stop using CNAME flattening, and set the A record status to “DNS only”, my sites run as expected.


I didn’t use CNAME.


Seems the downtime happens when the Cert renew?
Or it happens only because I downgrade my plan.
I got updated cert now.

Valid from
Wed, 13 Dec 2017 00:00:00 GMT
Valid until
Thu, 21 Jun 2018 23:59:59 GMT
COMODO ECC Domain Validation Secure Server CA 2


Are you saying that the issue resolved on its own? I’m doing some digging and want to make sure I understand what is happening.


The issue didn’t resolve on it’s own for me. I had to effectively bypass the cloudflare proxy in order to get my site to stop displaying the “ERR_SSL_VERSION_OR_CIPHER_MISMATCH” error. I believe there might be something wrong with the certificate renewal process.


When did you first experience your issue? There were some issues earlier today that I believe are resolved now. You can find those details here:



I’m experiencing the same issue. Setup the site in Cloudflare 1 hour ago and has enabled the HTTPS and suddenly getting the “ERR_SSL_VERSION_OR_CIPHER_MISMATCH” error on my site. SIte was working fine until I’ve enabled the HTTPS.

Can somebody please suggest any solution?


Same here.


Please don’t double-post. It makes it difficult to track progress. Your posts are already in this thread:


On the first day after activating ssl, website had error - not secure.

Second day ERR_SSL_VERSION_OR_CIPHER_MISMATCH - website not available at all.


Your certificate might not be active yet. What is the Status on your Cloudflare Crypto page. It’s in the SSL section at the top.


Thanks for quick reply!

There is no any status message.

"It may take up to 24 hours after the site becomes active on Cloudflare for new certificates to issue.

This setting was last changed 2 days ago"