https/SSL not working properly

I have a Wordpress site that breaks when ever I attempt to enter through HTTPS://. I get the “this page is trying to load scripts from unauthenticated sources” error message when ever it loads. After looking into the problem I took the following steps:

  • I installed the Cloudflare Flexible SSL plugin by One Dollar Plugin
  • I turned on Automatic HTTPS Rewrites on CloudFlare
  • and I tried installing a few HTTPS rewrite plugins
  • I am using MultiSite so I changed the SiteName for my blog subdomain to https://blog.nadiafrancis.com

None of this seemed to change anything. And the most confusing part is that it was all working a few days ago then suddenly stopped after I tweeked some page rules.

If any linked-to resource within your site is not available over https, even if you’ve enabled the automatic https rewrites feature && even if the links within your site have been automatically or manually rewritten from http to https but all/any/some of those links are only available over an unencrypted http link, you will experience the issue that you’ve stated.

  • Without actually looking at your sites code (which I’ve begun to do, and will finish doing, as well as manually checking links which are possible culprits) you’ll not be able to fully investigate and understand why you’re experiencing as the issue. But it is very important that it’s dealt with as modern browsers inform users that any site with insecure linked-to resources are not fully encrypted https sites.
1 Like

Thank you. After looking at you response I went to view the page source and was able to back track to the plugin that was producing a link that wasn’t compatible with https. It works now.

1 Like

Awesome! I’m happy for you.

2 Likes

This topic was automatically closed after 14 days. New replies are no longer allowed.