HTTPS/SSL is enabled but site still "not fully secure"

I have enabled SSL and installed the origin certificate on my website but when viewing in Chrome or Firefox the URL still shows as “Not Secure”
When I click the button, is shows:
“Your connection to this site is not fully secure”

but it also says the Certificate is “valid”

I’m stumped on how to fix the HTTPS setup.

You didn’t post the domain name, but it’s most likely Mixed Content.

Mixed content errors mean that your website is being loaded over HTTPS but some of the resources are being loaded over HTTP. To fix this you will need to edit your source code and change all resources to load over a relative path, or directly over HTTPS.

For example, if you load your images with a full URL:

<img src="http://example.com/image.jpg" />

You would want to change this to:

<img src="//example.com/image.jpg" />

By removing the http:, the browser will use whichever protocol the visitor is already using. An alternative option would be to enable the Automatic HTTPS Rewrites feature that can potentially fix these errors for you automatically. Do be aware that resources loaded by JavaScript or CSS will not be automatically rewritten and mixed content warnings will still appear.

See this Community Tip for further details

Thanks. The domains where this is happening are


hytechconstruction.com

Mixed Content: The page at 'https://studiorincon.com/' was loaded over HTTPS, but requested an insecure image 'http://teklecticprod.wpengine.com/wp-content/uploads/2019/07/cairn-2.jpeg?id=3661'. This content should also be served over HTTPS.

This link should also be HTTPS.

This most likely will solve the issue.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.