HTTPS Sort of working


#1

I recently registered my website here, and now it says the certificate is active. It works perfectly fine with no problems on my phone, and it says secure (It also redirects to HTTPS). But, when I visit it on my chromebook, it does not redirect to HTTPS, and when I type it in as HTTPS, I get a not secure error. It also will not let me connect at all. How do I fix this?


#2

Hi there. Would you be willing to provide the URL so some of us can check out what may be the cause?


#3

It is randomthings.ga.


#4

Thanks! I did some poking around with Chrome - I don’t have a chromebook but I assume that’s the browser you’re using.

Can you confirm if this is only occurring on the Blog page? You have mixed content error on that page:

Safari reports the same error on that page, but Firefox does not.


#5

That’s weird. It won’t redirect from HTTP to HTTPS anymore.


#6

No, it’s happening on all the pages. They all say “Not secure”, and if I try to type in https:// before the link it’ll say it’s failed to establish a secure connection.


#7

@andy Whenever I try to connect, this happens and I can’t use the website:

ERROR
Unable to complete URL request
An error has occurred while trying to access https://randomthings.ga/
Failed to establish a secure connection to 145.14.144.47.
[No Error] (TLS code: SQUID_X509_V_ERR_DOMAIN_MISMATCH)
Certificate does not match domainname: /OU=Domain Control Validated/OU=EssentialSSL Wildcard/CN=*.000webhostapp.com
Failed to negotiate mutually acceptable security parameters. The remote host may not support secure connections or the proxy server is not satisfied with the host security credentials.


#8

Hello @tristian.kelly560,

How to correct mixed-content errors: https://support.cloudflare.com/hc/en-us/articles/200170476-How-do-I-fix-the-SSL-Mixed-Content-Error-Message-

From the last log extract you provided, I do see an issue with the certificate corresponding to a domain name mismatch. For that, you’ll need to make sure that the certificate sitting at your Origin is correct (valid and trusted). If you don’t plan to change the certificate or because you can’t, you can also play with the SSL scenario for your domain: https://support.cloudflare.com/hc/en-us/articles/200170416-What-do-the-SSL-options-mean-


#9

Okay! I will definitely try that and see if it works. Thank you!


#10

Also, I’d like to temporarily disable SSL while I am working on this. I have turned rewrites and the certificate off, but it is still rewriting me to HTTPS so I cannot connect to my website.


#11

Don’t see that behaviour when i’m connecting to your website, fixed some how?


#12

@tristian.kelly560, sorry for falling off this thread a bit. I can’t entirely 100% replicate your hardware/software setup so reliable troubleshooting is a bit tough. Chrome on Ubuntu Desktop is about as close as I can get.

as @stephane stated, I’m not seeing any behavior that you’ve posted about other than the mixed content issue on the blog page of your site.

Have you tried visiting your site in a private tab an/or clearing your browser cache? Are you able to install a different browser and test with that?


#13

No, chromebooks are limited to only Chrome. I’ll try clearing my cache.