Https secure but www is not secure

Hi ,i am new member
My cloudflare is on ‘‘Flexible’’. ( full is showing error 525. anyway ,it’s fine for me flexible if i can redirect www.domain to https.domain with page rule.

I have the settings on ‘‘Always https’’
I am redirected correctly from http to https.
I want to redirect www.domain to = https.domain with page rule.
This is my page rule settings. picture: https://prnt.sc/vsnxny
Still i am not redirected. picture: https://prnt.sc/vsnwui

I am doing something wrong?
Thanks.

For me it is working. I’m getting redirected from www.grouparrow.ga ==> https://grouparrow.ga

Also SSL works here, but if you have installed an SSL Certificate on your Server change SSL mode to:

Full or
Full (Strict) (Better)

1 Like

I can’t ,it’s showing error 525 . i try to create origin certificate following the steps in internet ,i created it but still showing that so i give up from full.
it’s fine for me flexible if i can do the redirect.
maybe my browser history needs to be clean to be visible for me ,thanks ,i will try it.

Hmm these errors are showing up more and more. But still dont know why or on which end the problem is.

From what i read in internet ,it is from the origin server ,if the user doesn’t have certifcate for origin server ,but the problem is that i have certificate created for origin ,so no idea what is the problem ,anyway ,as i said flexible is really fine if the redirect works ,if the redirection works when you type www.grouparrow.ga and if redirects you to https://grouparrow.ga i am happy.

Just test it with your mobile phone with mobile internet and see if it works there.

In mobile it works ,but on my pc with clear browser history doesn’t work ,i am confused lol

Test with another browser, clear DNS cache and then try again.

Done.
power shell- done -
command - done.
browser history - done
Everything is clear .
Still same

May i ask ,if you type on your pc browser - www.grouparrow.ga if redirect you ,or mobile?

I can’t see Error 525 from my side. Your site is working.

Hi ,it’s working because i put flexible .

The problem is that:
i want to redirect www.grouparrow.ga to : https://grouparrow.ga

I see, but generally it is not advisable to set Flexible since your connection is not fully encrypted anyway (Cloudflare to server will still use HTTP).

Better way to solve the issue is to troubleshoot the SSL connectivity on the server side, if everything okay then you can set Full (strict) mode.

@sandro

Consider creating a page rule like this:

This is my page rule settings. picture: https://prnt.sc/vsnxny
Still i am not redirected. picture: https://prnt.sc/vsnwui

It’s redirecting from my side.

I want when someone type in google bar to search www.grouparrow.ga to be automatically redirected to https://grouparrow.ga .
If you are redirected from www.grouparrow.ga to https://grouparrow.ga ,then my pc needs clean:D

Yup, I think you need to clear your browser cache.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.