HTTPS requests killing site speed! Please help the NOOB!

ssl
wordpress

#1

I’m totally new to Cloudflare, and I’m not a server genius either…I’ve done everything I can to figure out how to do to speed up my page load time, but in GTMetrix under waterfall, I’m seeing that Cloudflare is causing alot of my slow page loads with what looks like HTTPS requests back and forth - or something. Here is the report from GTMetrix https://gtmetrix.com/reports/hikestgeorge.com/oS7xVX37. I don’t have a clue what to do and would welcome any help from you guys!!

Thanks,
Tim


#2

You have an SSL cypher mismatch/unsupported version error going on.

What level do you have the TLS set to within CloudFlare? I noticed I got that when I set the minimum level to TLS 1.3. I switched to TLS 1.2 for the minimum and is fine now.


#3

user329,

Thanks so much for your response! I have attached a screenshot of my cloudflare settings, and here is my latest score from gtmetrix https://gtmetrix.com/reports/hikestgeorge.com/SKecrLZ4. I tried playing with the TLS settings and it didn’t seem to make any difference on any of the four settings. Any other ideas?


#4

@user329, where do you see that mismatch/unsupported message?

What I see, and mystifies me, is that there are no Edge Certificates listed. Regardless of my SSL setting, I always have something in there. Let’s leave that alone for now.

Regardless, the site loads well for me, with the initial page load taking up the most time. It also passes the SSL test at Qualys:
https://www.ssllabs.com/ssltest/analyze.html?d=hikestgeorge.com

I see you have Autoptimize, but do you have a Page Caching plugin as well? That should speed up page load.


#5

It’s not giving the ssl error any longer… so must have resolved. Also, the site comes right up for me without delay.


#6

After running a test, http://www.webpagetest.org/result/180721_JV_1f753eb816ba822c0dead349a395378f/1/details/#waterfall_view_step1 , your ttfb is horrid. This is likely bc the page is being created at the visit and not cached as html on the server.

Do you have a cache (like Fastest Cache, or something like that - it precompiles the pages). Also, optimize your database. Also, check .htaccess that you don’t have a bunch of crap in there. Also, what version of php are you running?


#7

You guys are amazing! Thanks so much for helping me out! So, I’ve got WPSuper Cache, but apparently that isn’t doing the trick. I’ll try Fastest Cache. How often should I optimize the database? I do it about once a week with WPOptimize plugin. Is there another one that would be better? Running PHP version 7.2. Not sure how to do the .htaccess stuff…