HTTPS Redirects to 404 Page After Moving Site to New Server


#1

I’m trying to move a website from a dedicated server to a shared server, and after moving all the files over I pointed the A record to the new server and set the status to go through the Cloudflare proxy, however when I visit the site https://masterpiecesofmetal.com, it redirects to https://masterpiecesofmetal.com/404.html.

If I go to non-https it loads fine.

Edit
I was messing around with it, and got this error message to show that I think is related


#2

Your server seems to be redirecting everything to this 404.html page, but it’s giving a 302 status instead of a 404: https://redirect.li/http/?url=https%3A%2F%2Fmasterpiecesofmetal.com%2F

If you open the domain with Chrome Developer Tools open, you’ll see that both the page and the favicon.ico file are being 302-redirected to this 404.html. (THAT WAS until a moment ago. Now it is returning 200 for the html and 302 for the favicon.ico file.)

This kink of arrangement is typically done at the .htaccess as a way to put the site on “maintenance mode” to prevent Google from indexing stuff before the server is ready. When you moved from one server to the other, perhaps you used a tool that created this maintenance mode? I’d check the .htaccess.


#3

@floripare I disabled the htaccess file, but it doesn’t seem to have changed anything.


#4

I don’t know what to suggest other than to check with your hosting provider support, as this doesn’t look like a Cloudflare issue.