HTTPS redirect not working on other devices

Hey there,

I have enabled Redirect to HTTPS on my website, but when I head to the website without stating the https:// at the beginning of the URL, It just takes me to http://. It works on my workstation, but it doesn’t work on any of my other devices…

I decided to try using the diagnostic center, and that confirms that the HTTPS redirection is not working.
How do I fix this?

Without knowing the actual hostname with the issue, it’s difficult to diagnose.

I suggest you make sure that your SSL/TLS → Edge Certificates section has “Always Use HTTPS” and “Automatic HTTPS Rewrites” enabled.

1 Like

Wow, I don’t know why I didn’t think about that, Sorry for wasting your time.

I already had “Automatic HTTPS Rewrites” enabled, but I thought that basically done the same as “Always Use HTTPS”. Thanks!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.