Https redirect not working for static ipfs site


I have a static website on ipfs. I’ve set up CNAME with ‘’ pointing to ‘’ (and setup the corresponding txt records). The nameservers are on cloudflare. Https redirect on the SSL edge certificates tab is enabled.

The issue is that naked domain (without the www) and also ‘’ all open non-ssl connection.

Here’s a screenshot of my dns setup:

Any ideas what could be the issue?

Now, the interesting part is, I have another domain,, with exact same setup as above, with all the https redirects working perfectly. Screenshot of that is below.

Thank you!

1 Like

The only difference between the two domains that I can think of is that one is .com, which is a cloudflare supported TLD and the other is .app, which is not a TLD that cloudflare supports. Maybe cloudflare does something different in these two cases.

1 Like

Ok, I solved the issue of naked domain not redirecting to https by adding a URL forwarding page rule from* to$1.

I’m not sure why this is not needed for my other domain.

Anyway, the only url now that is not redirected to https is “”. My understanding is that this is because the www subdomain is handled by (via CNAME record) so it’s not proxied. Technically, because cloudflare also manages the target url, I would expect them to be handle the redirect to https. But I’m not sure if this is solvable. This is not a big deal, but let me know if anyone solved this.


.app domains are https only

Cloudflare supports .app domains.


Got it - thanks for clarifying. That explains why the .app domain didn’t need page rules to force https.

Still curious if anyone figured out a way to force https on the www subdomain when it points to cloudflare-ipfs (i.e. forcing https in the ipfs scenario).

Hi @tverona,

For now, having HTTPS forced is a custom configuration on Cloudflare side. If you are willing to enable HTTP to HTTPS redirection, please comment below with the domains you want it on.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.