Https Problem with Jimdo

I need to solve a problem with a domain of a Jimdo hosted website:
Jimdo is only hosting the webpage and has registered the domain, but has no mailing feature.

Following their support recommendation, I moved the domain to my Webhoster, and added a CNAME record for jimdo (*):

www CNAME web.jimdosite.com

In Jimdo, this is resolved to:
www.mydomain.de => https://mydomain.jimdosite.com

Problem: the call to https://www.mydomain.de does not work, I get: SSL_ERROR_INTERNAL_ERROR_ALERT

So I tried everything with Cloudflare SSL (flexible, fixed,…) configuration, but I don’t get any success.

This is my Cloudflare DNS configuration:

Questions:

  1. Any ideas on this problem?
  2. I don’t know if CNAME is really the best solution, it is just recommended by jimdo. If you see another setting that works, let me know

Any other solutions are welcome as well, I just want to avoid costs for a SSL Certificate on a redirect-only domain!
mydomain.de is only used for a 301 redirect to mydomain.jimdosite.com (this is stupid but given by the system).
So I need just a solution for users with the links https://www.mydomain.de to be redirected without SSL Error?

This is fixed due to customer contracts:

  • Jimdo with their internal redirect to mydomain.jimdosite.com,
  • Domainfactory as webhoster.
    Cloudflare is not necessary but seemed a good solution for me. .htaccess is available as well

(*)https://help.jimdo-dolphin.com/hc/de/articles/360001233686-Wie-leite-ich-per-CNAME-auf-meine-Jimdo-Website-weiter-

At the moment, you’re bypassing cloudflare. What happens if you edit the dns records from not proxied :grey: to proxied :orange:?

1 Like

yes this helped, and I found another tutorial that recommended to add a page rule forwarder, now it works

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.