HTTPS Port 443 not redirecting properly

For some reason everytime I’m running my server on port 443 and I can access it via https://[IP]
I cannot access it via Cloudflare with https://[DOMAIN]…
But if i’m running my server on port 8443 I can access it via https://[DOMAIN]:8443

Any idea what’s causing it/?

Domain?

I’m running my website on both 8443 & 443 right now:

those two works:
domain + port 8443:
https://bodyprolife.com:8443/app

ip:
https://..*.39/app

this one doesnt:
https://bodyprolife.com/app

And the DNS records in your control panel point to that *.*.*.39 address?

If that is the case I’d look for some firewall-ish configuration which might block Cloudflare from connecting to 443.

Yes it’s directed to this IP.

I’ve opened 443 port via Google Cloud firewall that’s why I can access it via https://IP

but for some reason via domain it’s not working…

What is TLS mode under “Crypto”? Flexible or one of the Fulls?

SSL is set to Flexible.
TLS 1.3 Enabled
Minimum tls version 1.0
always use https->true

Set it to “Full strict”.

1 Like

It Works!!
Thank you!

What was the issue?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.