HTTPS on a local server

I installed Cloudflare’s certificate for on a local Apache server with no Internet access, so that all traffic get redirected to Everything works fine server-side but Chrome keeps showing the alert “Server’s certificate is not trusted”. I there a way to fix this?

The reason I want to make https work on the local server is to enable a feautures that Chrome restricts to secure sites (e.g., use of VIDEO tag).

It’s basically a self-signed certificate that only Cloudflare trusts. You can try adding their Origin CA to your local system:

1 Like