Https not working (Google Cloud, GoDaddy)

Hi,

I recently buy gadsby.me from GoDaddy, then I setup f1 micro instance from Google and I assigned Static IP address.

I setup docker-compose wordpress and I check with static ip if it’s live, then I changed my name servers from GoDaddy to Cloudflare. The setup screen from Cloudflare showed me the Google Cloud’s Static IP so everything looked fine.

The results are confusing me, I am not sure if I miss something.

http://gadsby.me/ = does not work / sometimes work when it's not go https
http://www.gadsby.me/ = does not work
https://www.gadsby.me/ = doesn't work
https://gadsby.me/ = doesn't work

> https://discourse-cloud-file-uploads.s3.dualstack.us-west-2.amazonaws.com/cloudflare/original/3X/9/5/95888ab90a7554848732b827f19383de0fb38f59.png

> https://discourse-cloud-file-uploads.s3.dualstack.us-west-2.amazonaws.com/cloudflare/original/3X/7/6/7636462ce7b58b4a16ec7a1bf3350ba8e14ca6c8.png

As it stands, gadsby is using GoDaddy name servers and does not resolve.

Thank you for your respond, I waited like couple hours and it was still same so I wanted to rollback everything to default. I’ve made DNS back to GoDaddy to see if it’s works there;


But it still not working.

CONTAINER ID        IMAGE               COMMAND                  CREATED             STATUS              PORTS                                 NAMES
0070f48bd744        wordpress:latest    "docker-entrypoint.s…"   2 hours ago         Up 31 minutes       0.0.0.0:80->80/tcp                    wordpress-docker-compose_wp_1
c44283afc551        mysql:latest        "docker-entrypoint.s…"   2 hours ago         Up 31 minutes       127.0.0.1:3306->3306/tcp, 33060/tcp   wordpress-docker-compose_db_1
top - 19:58:32 up 37 min,  1 user,  load average: 0.00, 0.00, 0.04
Tasks: 107 total,   1 running,  71 sleeping,   0 stopped,   0 zombie
%Cpu(s):  0.3 us,  0.0 sy,  0.0 ni, 99.0 id,  0.7 wa,  0.0 hi,  0.0 si,  0.0 st
KiB Mem :   588616 total,    61316 free,   358764 used,   168536 buff/cache
KiB Swap:  4194300 total,  3887612 free,   306688 used.   118784 avail Mem

So I’ve changed back to Cloudflare and whenever I try https-gadsby.me not working but http-gadsby.me is working. Is there step that I missed?

Did https work before you changed it back to Cloudflare?

First time I setup docker compose I’ve changed to Cloudflare and waited few hours but it didn’t worked. So I removed instance and created new one but I’ve tried to use something else than Cloudflare so that’s also didn’t worked. So I back to Cloudflare. I’ve checked with few SSL checker website and they show cloudflare SSL.

https://www.sslshopper.com/ssl-checker.html#hostname=gadsby.me

This topic was automatically closed after 30 days. New replies are no longer allowed.