HTTPS not support in Chrome Windows xp


#1

I enabled “Always use https” in Crypto but found that Chrome in XP not support.
Error “This site can’t provide a secure connection.”

What should I do to fix this problem?


Pro plan plus Dedicated SSL certificate or Pro plan only?
#2

You need a paid plan in that case.


#3

I believe a dedicated SSL cert will also work.


#4

No idea, I would assume it is cipher and not certificate related but I guess thats something only support can clarify for sure :man_shrugging:

The article states

Note: If you need more compatibility with older browsers/operating systems, such as Windows XP and Android 3.0 and earlier, please check out our Pro, Business, or Enterprise plans.


#5

I also argue that XP support should not be considered - XP itself is no longer supported by MSFT, and Google has a big warning on the new tab pages about how Chrome will not receive updates on XP.


#6

Google Chrome browser in Windows XP not support HTTPS.
Error “The site can’t provide a secure connection.”

I read the article only paid plan can support.
Which plan should I choose? Pro plan plus Dedicated SSL certificate or Pro plan only?

Screenshot_9


#7

It looks like the Pro Plan would be enough.


#8

Also, if possible, could you post your domain? I believe even chrome on XP supports certificate SAN’s and SNI, so the issue might not be related to the free plan.


#10

Is this the solution in Pro plan?
disable Legacy Browser Support under the Crypto page on the Cloudflare dashboard


#11

I think that Enable Legacy toggle is gone. I don’t see it in my Pro Plan site. That’s Biz and Enterprise only.

EDIT: It looks like “Disable Legacy” is the default here, but Biz and Enterprise plans let you Enable it. The wording is pretty weird:


#12

eunited.com.my


#13

I just purchased Pro plan.
Where is the “Legacy Browser Support” settings?


#14

In the ‘Crypto’ section.


#15

Problem solved. I upgraded to PRO.
Just need to wait untill the configuration automatically done by Cloudflare.
Now I have 3 certificate. SHA 2 ECDSA, SHA 2 RSA and SHA 1 RSA.


#16

I’m not seeing any Legacy option in the Crypto settings page of my Pro Plan site. I do have a Dedicated Cert and have disabled Universal SSL if that might be why.