Https links on website being redirected to http

Hello everyone,

I’ve a website being proxied by cloudflare, that works without any issue, but if I try to open any link on it, it opens as http, but on browser if I pass with mouse on link, without clicking, I can see that it shows the “https” before the url.

If I then try to add https on prefix, manually, it works.

I really dont know what it is happeanning.

I’ve tried on chrome and edge, and it happeans at least in those.

Anyone knows what can be?

Thanks in advance!

Hello @jajam,

Do you have any active page rules? Did you try the “Always use HTTPS” under Edge certificates?

1 Like

I would firstly recommend you to secure your origin host / server.

Therefore, make sure you have got a valid SSL certificate and that it is properly installed at your origin host / server.

Select the correct SSL/TLS option at SSL/TLS tab of Cloudflare dashboard for your domain.
Use HTTPS for your domain.

Nevertheless, configure Automatic HTTPS Redirection option just in case, to make sure any HTTP links would be HTTPS (there is also another Always Use HTTPS option which you can enable afterwards).

I would not recommend having and configuring a redirection in a vice-versa, like from HTTPS to HTTP.

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

If any other issues appear, follow the needed steps for troubleshooting from article below:

Regarding available SSL options at Cloudflare dashboard, check here:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings:


Damn, cannot believe that was disabled.

Enabling solved, thanks!!!

1 Like

What’s your encryption mode on Cloudflare, though?

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.