HTTPS is slowing the website load time

ssl
caching

#1

Hi,

I have just upgraded to CloudFlare Pro. I have the HTTPS certificated ACTIVE. When I used the option “Always use HTTPS” in CloudFlare, the website loading time went from 3 to 10 seconds.

I am using WP-Rocket as Wordpress Plugin ad integrating it with CloudFlare. My website does not have much traffic, only the paid advertising I do.

Here is a screenshot of before HTTPS applied:http://nimb.ws/gfReUA

Here is the website´s url I am worried about: http://atracaodeclientes.com.br/clientes-sob-demanda/

Any help would be much appreciated.

I am new to CloudFlare!!!

Thanks in advance


#2

Most of your site is pretty fast. The parts that take the longest are slowed down by your OptimizeMember plugin. Its output is not being cached by Cloudflare. Since it’s CSS, you would be better off disabling this feature and let Cloudflare minimize and cache it.

The slower parts are external to your site: Google, Facebook, Trackcmp. There’s not much you can do about this.

Your site also makes some calls to HTTP, which causes a Mixed Content warning. In your Cloudflare Crypto settings page, make sure you turn on “Always Use HTTPS” and “Automatic HTTPS Rewrites.” This should take care of most, if not all, of the Mixed Content warnings.

Overall, you site loaded in less than 4 seconds in my GTMetrix test:


#3

I take some of that back. The OptimizeMember plugin is what’s slowing the site down. Those external calls are all waiting for the OptimizeMember data to load before they will load.


#4

Thank you so much for your attention and care sdayman! I really appreciate it!

As it is a membership plugin. I cannot uninstall it from my website. Do you have any suggestion on how I could improve the website speed without uninstalling the plugin? If it helps, I am using WP-Rocket plugin too.

Again! Thank you so much!


#5

No. Nothing is going to show up on your visitor’s browser until those OptimizeMember resources load.

As for full load, Facebook and Hotjar are also slowing things down. But at least by this time, the visitors have something to look at. Again, that plugin is what your visitors have to wait for before they can view this page.

The good news is on my very fast home connection, that page shows up in about one second. By two seconds, it’s fully loaded.


#6

Thank you again. I can remove Hotjar script but not Facebook. I will remove and see how much speed I can gain. For the OptimizeMember I will have to remove the members area from this domain and put in another domain. It will take time to do. Maybe in the near future.

Again, I really appreciate your support!


#7

sdayman, I found a solution. I found this plugin which allows to disable plugin for a specific page. I disabled OptimizeMember for my page and my website speed load was from 3.8 to 1.7 seconds. Amazing!

Here is the GTMetrix link: https://gtmetrix.com/reports/atracaodeclientes.com.br/pTjW6kLo

I can make it load much faster but I will leave it as it is for now.

Thank you for your help.


#8

Also, you should try out Rocket Loader, it defers JS parsing (your worst score on GTM) and should speed up first paint time.


#9

Thanks Judge. I will have a look and make the changes. Let´s see how it will impact the website and the loading speed.

I really appreciate your support!