Https -> http


#1

Hi, everyone!
I want to index my site in search engines as HTTP back again.
So I put .htaccess in root folder with redirect rules:
RewriteCond %{SERVER_PORT} ^443$ [OR]
RewriteCond %{HTTPS} =on
RewriteRule ^(.*)$ http://www.mysite.com/$1 [R=301,L]
But It doesn’t work. Seems like Cloudflare force ignoring the redirect.
I use the Flexible SSl mode for whole site.
Please help!


#2

hi @user5941 have you checked to see if ‘Always use HTTPS’ is enabled you will find this in your crypto tab


#3

Hi, danstock
Thanks - forget to say This options is off.
The site is available for both https and http, but I want it will only http.


#4

hi @user5941 in your crypto tab turn SSL to ‘OFF’

Off: No visitors will be able to view your site over HTTPS; they will be redirected to HTTP.


#5

@danstock is correct. You don’t actually have to do anything on your origin server to force traffic over HTTP. You just need to disable the SSL setting within the Crypto tab.

That said, I would advise against making this change, even if you don’t have any sensitive information which needs to be encrypted on your website. A few reasons for this:

  1. Search engines, such as Google, care about https, and may penalize you for not using it. In fact browsers such as Chrome will mark websites as not secure when they use http: https://developers.google.com/web/updates/2016/10/avoid-not-secure-warn
  2. With http2, which requires https, you can get several performance optimizations (i.e. Server Push), which may help improve performance of your website overall, and subsequently improve indexing results.

In general there is no good reason not to use https on any website, especially as services such as Cloudflare make the certificate management extremely easy, so we always recommend utilizing it where possible. Of course in the end it is entirely up to you – hope this information was helpful!


#6

@Martijn, @danstock - thank you!