HTTPS for media server, SSL with certbot

Hello! I’m very new to hosting so please bear with me.

So, I’m trying to host my media server (Jellyfin Media Server, very similar to Emby). I want to create a certificate for my domain with it, but it gives me the error below.

Please enter in your domain name(s) (comma and/or space separated) (Enter ‘c’
to cancel): mydomain . com
Requesting a certificate for [mydomain.com](http://mydomain.com)
Performing the following challenges:
http-01 challenge for mydomain . com
Waiting for verification…
Challenge failed for domain mydomain . com
http-01 challenge for mydomain . com
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

* The following errors were reported by the server:Domain: [domain.com](http://domain.com)
Type: unauthorized
Detail: Invalid response from
https://domain.com/.well-known/acme-challenge/Tx17EvcdB9CQQz2-cvG95zkdDOtWcM_6_6C_zj_gA3w
[2606:4700:3031::6815:4939]: "\n<!–[if lt IE 7]>\n <html class=\"no-js "To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address.

I’m presuming that it’s because of the reverse proxy, but I don’t really know for sure.

The reason I’m doing this is because Jellyfin needs it’s “own” certificate in order to make HTTPS work. To translate it:

  • Checkbox: “Obligate HTTPS”
  • “Modified SSL Path”
  • “Certificate password”

Could anyone help me out? Thanks!

The HTTP Challenge of Certbot cant run with Cloudflare Proxy in front of it. You need to deactivate the Cloudflare Proxy wait a moment for the DNS to Update, then you can use Certbot and after that you can reactivate Cloudflare again.

Thanks, that works. Even though Jellyfin itself is giving issues right now but that (I think) doesn’t have anything to do with CloudFlare.

This topic was automatically closed after 29 days. New replies are no longer allowed.