Https err_ssl_protocol_error

Hello,
I am able to access my EC2 instance through Cloudflare with HTTP requests but not able to do the same with HTTPS and getting the following error.

This site can’t provide a secure connection

precium.remotestate.com sent an invalid response.
ERR_SSL_PROTOCOL_ERROR

My SSL/TLS encryption mode is Flexible with the following settings:

Always Use HTTPS: OFF

Minimum TLS Version: 1.3

Opportunistic Encryption : On

TLS 1.3 : On

Automatic HTTPS Rewrites : Off

I am posting this here after trying everything posted similar to this topic on this community. Some post also mentioned that it takes some time but I have already waited for 6-7 hours but still the error persists.

Please help.

That hostname is not proxied by Cloudflare. The DNS record is probably set to :grey:.

1 Like

Your dns record says not proxying thru the cloudflare -
https://toolbox.googleapps.com/apps/dig/#A/precium.remotestate.com

You need to turn on cloud at your dns record(A) and it will then manage ssl for you.

1 Like

That fixed the issue. But initially it was not working when it was set to proxied. Maybe it takes some time to setup.
Thanks for the quick reply and solution. Cheers.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.