Https doesn't work, but http does


#1

Hey! I started a Google Cloud instance with a static IP, and I decided to buy a domain on GoDaddy.
I connected GoDaddy to Cloudflare, and now my website is active on CloudFlare. However, http://protonbackpacks.com works fine, but if I connect through https://protonbackpacks.com it returns me a 502 Bad Gateway error (by Cloudflare). My site will be a store, so https is necessary.


#2

Currently, the site isn’t on Cloudflare. What’s the SSL setting in your Crypto page at Cloudflare? Is it Flexible, Full, or Full (Strict)? How about its Certificate Status?


#3

It’s back again. I tried removing and readding it. Now it doesn’t show anything. The site is active on Cloudflare, and the SLL is Flexible as I may see.


#4

It’s working for me. Default Wordpress theme.

It has a mixed content warning, due to an http://IP address hardcoded into some resources.

So…so far, so good. Now to iron out those kinks…


#5

Changed the URL in Wordpress settings :slight_smile: By the way, after you connect through https, does my site look broken? Like everything is not loading?


#6

Ok, that’s better, but Flexible SSL needs a little bit of help. Try this plugin. Read the instructions on that page as well.


#7

Thanks man, it works <3


#8

This topic was automatically closed after 14 days. New replies are no longer allowed.