Https doesn't work but http does work

Answer these questions to help the Community help you with Security questions.

What is the domain name?
www.coldplungesg.com

Have you searched for an answer?
Yes - but none seem to provide a solution that has worked

Please share your search results url:
https://community.cloudflare.com/t/https-is-not-working-on-my-domain/609345

When you tested your domain, what were the results?
http://www.coldplungesg.com and http://coldplungesg.com both work.
https://coldplungesg.com and https://www.coldplungesg.com doesn’t work on my pc. However when I tried in incognito mode, the non-www

Describe the issue you are having:
As above - when trying to go to the website with https, it fails. I registered the domain with GoDaddy, then moved to cloudflare. The URL redirects to a booking platform (simplybook) who hosts the site. They have an SSL feature which I’ve enabled.
In cloudflare I’ve got automatic https rewrites

What error message or number are you receiving?
Godaddy error page saying that the domain is parked and in chrome browser near URL bar it says site is not secure.

What steps have you taken to resolve the issue?

  1. Tried changing settings on cloudflare and looking up issues on community site

Was the site working with SSL prior to adding it to Cloudflare?
No - had issues with godaddy as well.

What are the steps to reproduce the error:

  1. try going to https://www.coldplungesg.com or https://coldplungesg.com

Have you tried from another browser and/or incognito mode?
Yes

Please attach a screenshot of the error:

You should pause Cloudflare, get SSL working on your origin server with direct connections first, then unpause Cloudflare. It’s hard to debug a misbehaving origin server when it is behind Cloudflare.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.