HTTPS and HTTP doesn't work

I bought my domain from GoDaddy and registered CloudFlare’s namespace at GoDaddy DNS setting.

I have set DNS as follows:
[Type: A] [Name: pickkapiserver.online] [Content: 52.78.173.204]
[Type: CNAME] [Name: www] [Content: pickkapiserver.online]

if I directly access by IP address, then it works normally.
However, both
http://pickkapiserver.online:3000 and
https://pickkapiserver.online:3000
don’t work.
Any reasons why? (For testing purposes, I have set ‘Always Use HTTPS’ to false)

my website domain is:
pickkapiserver.online

to get response, access:
pickkapiserver.online:3000

That is not a supported port.

You can only use these https://support.cloudflare.com/hc/en-us/articles/200169156-Which-ports-will-Cloudflare-work-with-

Also, that is only HTTP, so you can never a secure connection there. You need to configure that for HTTPS.

Alternatively, unproxy your DNS records (switching :orange: to :grey:) and you can use any port you want.

1 Like

Didn’t know there were port restrictions…
I chose to unproxy my DNS records(disabled all of them) and still don’t seem to work…

After unproxying, accessed with the same url:
http://pickkapiserver.online:3000/

Thats probably a DNS propagation issue. Just wait a couple of hour or try to flush your DNS cache.

It now seems to work -> http://sitemeer.com/#pickkapiserver.online:3000

Thanks! now http is properly working but https still isn’t…
any clue why?

This topic was automatically closed after 31 days. New replies are no longer allowed.