HTTPS and Adobe Portfolio


#1

Hi - first time poster and new to CloudFlare.

I am a photographer and have Adobe CC which includes portfolio hosting at (in my case) aldergrovephotography.myportfolio.com I thought I would use this rather than SquareSpace or anything else as I am paying for it anyway via my Adobe CC subscription - no point in paying for something twice!

Adobe lets you pretty seamlessly use a custom domain instead of their supplied *.myportfolio.com address so I purchased a custom domain via GoDaddy (www.aldergrovephotography.co.uk) but immediately encountered errors/warnings regarding security certificates in Chrome or when trying to use https in any other browser. Adobe’s support articles say that they currently support SSL certificates for *.myportfolio.com but not for custom domain names.

I therefore turned to Cloudflare to overcome this but I’m not having any success just now. I have updated GoDaddy to use the Cloudflare DNS and (as far as I can tell) my DNS settings are complete in Cloudflare, SSL is active and set to “flexible” (I have also tried “full”) but still https:// doesn’t work for me.

Can anybody tell me or suggest to me what am I missing?

Many thanks for any help you can give me.


#2

Appears to be working on my end. SSL lock in Firefox, Chrome and Safari. I see your SSL cert is from Cloudflare, and you are using Cloudflare DNS :man_shrugging:


#3

Yep. All seems to be in order. Are you still seeing issues, @aldergrovephotograph?


#4

Thanks everyone for your prompt replies.

It’s still not working for me on my home WiFi but it is working perfectly on a mobile connection. If I change my router settings to use Google’s DNS then it works fine as well. I guess my ISP’s nameservers or whatever haven’t been updated yet?

If it’s still like that on Monday I’ll give them a call to see how to fix it but thanks again to everyone for replying and confirming it works.

Martin.


#5

You can try flushing your DNS cache (Windows is easy …“ipconfig /flushdns” and see if that helps. May also want to clear your browser cache.


#6

Thanks. It’s doing it on multiple devices though, each of which works fine if I connected to my mobile phone and use the mobile network. I guess it’s either my ISP or my router then - hoping it will fix itself. If not, I will reset the router tomorrow (I have all config settings saved anyway) and will phone my ISP on Monday if need be.

Here was me thinking that setting up CloudFlare was going to be the hard part :slight_smile: lol


#7

Thanks Andy. Just tried it on my mobile phone (while not connected to my
WiFi) and I can see it working there too but it won’t work when connected
to my home WiFi. I guess by ISP’s nameserver is taking a bit longer than
expected to update…

Thanks again. I’ll mark this solved or whatever when I get home :wink: