HTTP3/quic not working


I tried refreshing page many time. HTTP3 is enabled but not working for my domain. (Working for google ads in same browser).

This is presumably a Chrome output. Chrome seems to support H3-23 only in the development builds at this point. Hence you cant use a regular build with HTTP 3 yet.

1 Like


I am little confused. It seems google ads/youtube/search using
alt-svc: quic=":443"; ma=2592000; v=“46,43”

it seems draft 46 which is working and draft 23 is not working?

The protocol you are referring to seems to be an extended HTTP 2 version with some QUIC aspects. Draft 23 seems to be different.

I cant guarantee that this is the reason, but it would be my understanding that it is. Also, is your Chrome version actually a development build to begin with?

no. I would like to download canary but i don’t know how to use command line in mac.

In this case I am afraid you wont be able to test HTTP 3 yet.

I installed chrome canary. Still the option to enable at command line is difficult to execute on macOS.

Thats something to take up with Google however :smile:

Installed chrome canary. and enabled quic. Still site working on H2.

You probably need to enable HTTP 3 and not QUIC, but thats really something that is better suited for a Chrome forum.

Written on cloudflare blog

And you ran it with both arguments?

No such argument exist.
open ‘/Applications/Google Chrome Chrome Canary’ --enable-quic --quic-version=h3-23

i tried seeing them via chrome://flags

Well, it requires these arguments. If they do not work you best take that to a Chrome forum.

Finally able to open using command line with required flags.
/Applications/Google\ Chrome\\ Chrome\ Canary --enable-quic --quic-version=h3-23

Still seeing http2. Now please suggest what should I do.

These flags are not shown in chrome//flags. Make sure you have Chrome Canary v79. I downloaded Chrome Canary from Google’s official site to try outh HTTP/3 and for some reason, Canary v77 was installed.

With --enable-quic --quic-version=h3-23 enabled, you should see the following in Dev tools on HTTP/3-enabled sites:

This topic was automatically closed after 30 days. New replies are no longer allowed.