HTTP2 Protocol not working on Cloudflare Tunnel

Thank you in advance for any help with this issue.

I’ve recently started using Cloudflare tunnel to access my home network. While I don’t have much data to transmit/receive I have very limited CPU resources and the system very quickly bottlenecks (around 10Mbit/s) using the default QUIC protocol.

I tried changing to http2 by using --protocol http2 in the tunnel configuration. Just changing this setting results in web pages loading very slowly or not at all and sometimes 502 bad gateway errors. Do I need to change some other settings for http2 to work correctly other than just setting --protocol http2 on the cloudflared.service?

The only other setting I’ve changed is to enforce strict SSL/TLS encryption.

In case it is relevant all the services I am connecting to are http://localhost:xxxx rather than https.