HTTP2 not working


#1

Hi there,
I know that CloudFlare supports HTTP2 and is enabled by default. However, I encounter a very strange thingy. If I use CloudFlare only as DNS service (grey cloud), when I check NGINX logs and networking tab on Chrome, I can see that the request to my website is made of HTTP2 which is perfect. However, if I enable CloudFlare (orange cloud) all the requests showing in the log are HTTP1.1. Also when I check the networking tab on Chrome I indeed see that the requests are going on 1.1

Any what is causing this and how to fix this ?


#2

Are you sure HTTP/2 is enable in Cloudflare? It’s located in the Network tab.


#3
  1. Cloudflare does not use HTTP/2 to connect to your origin server.
  2. Check @matteo’s suggestion for making sure your visitors can use HTTP/2 to reach Cloudflare.

#4

This topic was automatically closed after 14 days. New replies are no longer allowed.