Http to https not redirecting

Hello!

I’m having a heck of a time getting one particular page to redirect from http to https. All pages on my website properly redirect but one. I even made a page rule for this specific page and yet it doesn’t help.

Does not work
http://publicnode.org/.well-known/stellar.toml

Works
https://publicnode.org/.well-known/stellar.toml

What is it you want to achieve? You seem to only want an HTTPS redirect, so simply enable “Always use HTTPS” and save yourself the page rule.

1 Like

That’s all I want to accomplish, to redirect to https. I tried the always https but for some reason this page is super stubborn and won’t do it. Thus I tried the page rule to see if that would help.

What’s crazy is http to https works on all other pages as expected. Just not the one I linked.

Do you want to redirect everything to HTTPS or just this URL?

Everything, which is working, but for this one basted page.

Alright, can you disable that page rule and enable the global Always use HTTPS?

I heard that too, some say it works for them, others not…

I get forbidden page.

The 403 is eventually on HTTPS (though it still returns the content too), the redirect itself works.

$ curl -I http://publicnode.org/.well-known/stellar.toml
HTTP/1.1 301 Moved Permanently
Date: Sun, 15 Dec 2019 11:24:34 GMT
Connection: keep-alive
Cache-Control: max-age=3600
Expires: Sun, 15 Dec 2019 12:24:34 GMT
Location: https://publicnode.org/.well-known/stellar.toml
Server: cloudflare

I see, so maybe it’s a WordPress thing? The https address shows the content just fine for me.

Thats what I meant. It shows the content, but returns a Forbidden code at the same time.

Anyhow, the redirect does work. No need for a page rule.

OK, I’ll remove the page rule. Just need to figure why content isn’t showing right.

What do you mean by that? You just said it is showing right on HTTPS and as the redirect works, it should show. Right? Maybe it is a browser cache issue, try purging it.

So when you click on each of these, you see the same thing?

http://publicnode.org/.well-known/stellar.toml
https://publicnode.org/.well-known/stellar.toml

I get a redirect to a forbidden https on the first and the correct content on the second.

I do.

A redirect to a forbidden? Do you get the redirect or not? If you do, the redirect works and the Forbidden issue is a different one.

Can you open the network tab of the developer tools in your browser, load http://publicnode.org/.well-known/stellar.toml, and post a screenshot of that?

Can confirm that http is redirecting to the correct https page for me–same content.

@dhfisher, there’s a good chance that your browser has an old, invalid 301 cached. 301 redirects generally get cached for a long time. Try opening the page in an Incognito/InPrivate window.

1 Like

Thanks friend! It is working now. At one point it was something beyond the browser, but I did just clear my cache and it works now! Woot!

This topic was automatically closed after 30 days. New replies are no longer allowed.