HTTP to HTTPS file requests return 403 Forbidden

Hi there,

When I try to access HTTP://mywebsite.com/file.txt it should redirect me to HTTPS://mywebsite.com.file.txt . Instead, it returns a 403 forbidden error.

Is there an option in the free plan that could have caused this?

Thanks

Full URL?

aquanswers.com

The full URL actually.

Requesting http://aquanswers.com/wp-content/uploads/2019/05/how-to-get-rid-of-green-water-in-aquarium.jpg seems to work fine

I am a bit new to this so correct me if I’m wrong…

If I have my image hotlinking turned off this should’ve not worked, correct?

Also, the problematic file is http://aquanswers.com/ads.txt

Thanks

Redirects fine for me too.

image

So could we assume it’s a serverside cache issue then (because I still can’t access it from here)?

Thanks

I would rather say it could be a cache issue of your browser. Alternatively it might be that your server sent a 403 at some point and the Cloudflare PoP you are accessing still has that cached.

Generally though, the redirect works fine. Also check out http://sitemeer.com/#aquanswers.com/ads.txt - all locations get a 301 for the HTTP version.

Okay, thanks. I wanted to exclude CloudFlare from the equation.

If I click Purge all cache (which I did already 2 days ago but no change) shouldn’t that clear the cache of the PoPs?

It should. Should it be cached on Cloudflare, that should remove that entry. If you still get a 403 then I’d check the browser. You are not going through any additional proxy in your browser, are you? Have you tried a different browser?

Yes, definitely, tried them all + proxies. So this points to a serverside cache. Thanks a lot!

This topic was automatically closed after 30 days. New replies are no longer allowed.