Http status: 404 not found

Answer these questions to help the Community help you with Security questions.

What is the domain name?

Have you searched for an answer?

Please share your search results url:

When you tested your domain, what were the results?
HTTP STATUS: 404 not found

Describe the issue you are having:
“I am encountering a ‘HTTP STATUS: 404 Not Found’ error on both my webpage and titlebar after implementing SSL through Cloudflare. Initially, I suspected that the issue might be related to my hosting provider, GoDaddy. However, when I switched to their default name servers, my site started working without SSL. The problem resurfaces when I change the name server to Cloudflare, resulting in the aforementioned error on my website. Could you please guide me on how to resolve this issue?”

What error message or number are you receiving?
‘HTTP STATUS: 404 Not Found’

What steps have you taken to resolve the issue?

  1. Reset the godaddy hosting and domain
  2. tried to pause and start cloudflare ssl the deleted and installed in again
  3. Search the community section did find the answer

Was the site working with SSL prior to adding it to Cloudflare?

What are the steps to reproduce the error:

  1. visit the site

Have you tried from another browser and/or incognito mode?
Please attach a screenshot of the error:

That’s not what I see

Here it returns a 404 as well.

And of course, no valid certificate :wink:

1 Like

That’s the first issue you need to fix, then contact your host about what @anon9246926 posted.

1 Like

Hello, yes, you can view this message. However, please note that it is temporary. Kindly check it again. When I attempt to open this URL on either my phone or laptop in incognito mode, it displays a “404 Not Found” error.

What should I do any solution??

Kindly refrain from kindly asking me to do anything.

And I did check again.

It displays the same screen I previously posted.

Here’s the cURL output which displays the same thing.

$ curl -i
HTTP/2 200
date: Wed, 21 Jun 2023 21:54:20 GMT
content-type: text/html
last-modified: Wed, 26 Oct 2022 13:18:02 GMT
vary: Accept-Encoding
cache-control: no-cache, no-store, must-revalidate
pragma: no-cache
expires: 0
cf-cache-status: DYNAMIC
report-to: {"endpoints":[{"url":"https:\/\/\/report\/v3?s=y3hSaviodQEmXDwHNvksvlgk2emOn9mQH6LcGBnncYf3LRIJyPGZ6ovp8Mw7BFNNmzbCNkjfw%2Bj0yHDL%2BltpQxNunMYaRWJY7cLVYYq%2Ft2ytDT8OAiBeFL11iO9tOEGn%2F6NqvxJjjcjAs6gtF%2F4Nx6XtL8rFqQ%3D%3D"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 7daf7d4cea4c17cb-MEL
alt-svc: h3=":443"; ma=86400

<!DOCTYPE html>
<title>Coming Soon</title>
<meta http-equiv="content-type" content="text/html; charset=utf-8" >
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<style type="text/css">
body {
  /*background: linear-gradient(90deg, white, gray);*/
  background-color: #eee;

body, h1, p {
  font-family: "Helvetica Neue", "Segoe UI", Segoe, Helvetica, Arial, "Lucida Grande", sans-serif;
  font-weight: normal;
  margin: 0;
  padding: 0;
  text-align: center;

.container {
  margin-left:  auto;
  margin-right:  auto;
  margin-top: 177px;
  max-width: 1170px;
  padding-right: 15px;
  padding-left: 15px;

.row:before, .row:after {
  display: table;
  content: " ";

h1 {
  font-size: 48px;
  font-weight: 300;
  margin: 0 0 20px 0;

.lead {
  font-size: 21px;
  font-weight: 200;
  margin-bottom: 20px;

p {
  margin: 0 0 10px;

a {
  color: #3282e6;
  text-decoration: none;

<div class="container text-center" id="error">

  <svg height="100" width="100">
    <circle cx="50" cy="50" r="31" stroke="#679b08" stroke-width="9.5" fill="none" />
    <circle cx="50" cy="50" r="6" stroke="#679b08" stroke-width="1" fill="#679b08" />
    <line x1="50" y1="50" x2="35" y2="50" style="stroke:#679b08;stroke-width:6" />
    <line x1="65" y1="35" x2="50" y2="50" style="stroke:#679b08;stroke-width:6" />
    <path d="M59 65 L83 65 L75 87 Z" fill="#679b08" />
    <rect width="20" height="9" x="70" y="56" style="fill:#eee;stroke-width:0;" />
  <div class="row">
    <div class="col-md-12">
      <div class="main-icon text-success"><span class="uxicon uxicon-clock-refresh"></span></div>
      <h1>Future home of something quite cool.</h1>
      <p class="lead">If you're the <strong>site owner</strong>, <a href="/cpanel">log in</a> to launch this site</p>
      <p class="lead">If you are a <strong>visitor</strong>, check back soon.</p>



FWIW I used a private session each time.

Yes, you are correct. The same issue is displayed on my end as well. Yesterday, I contacted GoDaddy support, and they advised me to remove the custom nameservers and use the default GoDaddy nameservers. After removing the custom nameservers, my website started working, but without SSL. GoDaddy suggested that the problem might be with Cloudflare, so I was hoping you could investigate during our debugging session. Unfortunately, we were unable to resolve the issue at that time. As a result, I have decided not to make any further changes for the next 12 hours. During this time, you can check if the 404 error still persists.

I think the problem is from cloudflare side we are using zero ssl please avoid debugging thanks for your help guys…

You need your site to work correctly with SSL before you add Cloudflare.

It is working fine If I remove cloudflare nameservers…

Your site does not load over HTTPS. I would not consider that to be:

Fix that and Cloudflare should work correctly.

“How can I resolve this issue? I am perplexed because my website is functioning flawlessly. I used ZeroSSL, so how can you claim that the problem does not lie with Cloudflare? Please visit the URL now and check how my site loads seamlessly over HTTPS.”

It does appear to load from the origin over HTTPS now. At the time of my earlier reply, the page load failed and my browser presented a warning that no HTTPS site was available. Perhaps you were still getting your ZeroSSL certificate deployed when I tried to visit the site.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.