HTTP(S) tunnel works, but not smb/ssh

I admit I don’t totally know what I’m doing.
My goal is to make my applications available on the internet, as currently they are behind CGNAT.
I’ve installed the tunnel like this: cloudflared service install [code]
I’ve created several addresses under Zero trust → Networks → Tunnels.
Everything that is http/https based - works fine.
But I can’t get my ssh and smb working, even though I have such options to choose from:

What am I doing wrong?

Hello,

This guide below details how to get SSH and SMB to work with Tunnels.

If you have any further questions on that let us know here. So we can provide further help.

CJ313

Thanks for reply.
I have followed this:

Basically what I have done is:
On Networks → Tunnels I have one tunnel, and in that tunnel I have added a subdomain.domain.com with SSH protocol selected and my local IP provided.
Then I have one container in my server running cloudflared.
I have also added the config per instruction from link above. Restarted cloudflared.

I can access my target server by typing from within the container, where cloudflared is running, and this works well:

ssh [email protected]

But this does not work from any other local machine and does not work from outside.

What else do I need to do?

Have you installed and configured Cloudflared on the client machine?

Thank you for this hint. I’ve installed it on the client now, and it worked. I was under impression that nothing needs to be done on client side, so I was wrong.

I’m facing a new issue now. My tunnel has just stopped working:

  • all of my hosting sites return error 1033.
  • when connecting to ssh, I get: kex_exchange_identification: Connection closed by remote host; Connection closed by UNKNOWN port 65535

I have not changed anything, did not mess with the server etc. It just stopped working, which is a huge red flag.

What I tried:
On Cloudflare’s management panel it says Status: DOWN.
On server, top reveals that cloudflared is running. ping to google goes OK, so it has internet connection.

cloudflared tunnel list - returns one tunnel, so it should be up?

Anyway, I have reinstalled cloudflared tunnel and it started working again. No idea what happened. How do I make sure this does not happen again?