HTTP redirect instead of HTTPS

Hey there,

I activated Cloudfare two days ago and was delighted with the speed increases.

However, I have just discovered that it has completely stopped users accessing our service. We send users to a form from our website, however cloud fare was sending them to http instead of https.

In addition to that it kept presenting Wordpress’ (expired) certificate instead of ours from Heroku.

I’ve urgently turned the name servers back to Wordpress but would really like to use Cloudfare but am super concerned about trying it again as we’ve lost money due to this error

Could anyone please advise?

Thanks,
Jack

Would you mind sharing your website?
Without a URL it’s hard to look into

Well, as you stated you are not longer using Cloudflare:

You could have just disabled Cloudflare in the Dashboard settings. Please do this, and change NameServers back to Cloudflare. Then, when asked activate Cloudflare (unpause) so we can debug it.

Thanks

1 Like

Thanks, I paused it.

So, changing the name servers doesn’t stop Cloudfare from being operational?

What happens to the website if I change the name servers back whilst cloudfare is paused? It wouldn’t then have the Wordpress name servers I assume which would stop it from working entirely?

Thanks a lot

Pausing Cloudflare puts it in DNS-Only mode. It’s effectively the exact same setup you have with your non-Cloudflare name servers, as it’s just publishing your DNS records, which should perfectly match your non-Cloudflare name servers.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.