Http:// - ok but https:// - 521 error

Webserver is ok, but cloudflare doesnt see it :frowning:

…edited…

Hi @psych0tr1a,

Did your site work with HTTPS before you added Cloudflare? If not, that’s the problem here.

1 Like

Thank you @domjh. Can you gove me more info?

If you pause Cloudflare (bottom right under advanced actions) and wait 5 minutes, does your site work with HTTPS? If not, you need to fix that.

Another domain name works fine with this server and cloudflare🤷‍♂️

It sounds to me that your server is not properly configured for HTTPS, which @domjh has asked about twice so far with no answer from you. We can’t help with that lack of information.

3 Likes

…edited…

Looks like emoji domains issue

That server isn’t configured for HTTPS. It’s refusing the connection.

2 Likes

…edited…

Then don’t use HTTPS for your site.

2 Likes

dude, i need https, thats why i want to use cloudflare.
i want to make chain
server -http- cloudflare -https- users

Ah, then it sounds like you want something like this:
Fake_Centred-1

3 Likes

@domjh pause doesnt helps

That’s because of what @sdayman already said. Your server needs SSL for your site to be secure.

Cloudflare does offer origin certificates that you can configure on your server if you want to just use Cloudflare for HTTPS.
https://developers.cloudflare.com/ssl/origin-configuration/origin-ca

1 Like

…edited…

It does require it if you want your site to be secure. Any site that you want working properly over HTTPS needs a certificate on the server.

I would guess that you either do have a cert for that domain or you have your SSL/TLS mode set to Flexible (very bad idea - see Why flexible SSL mode is not the best choice).

1 Like

@domjh

…edited…
Same settings, same server, different domains.
the problem is clearly not in the ssl between server and cloudlfare, but i will setup it today.

If you have any new idea, please let me know.

This discussion is going in circles. If you want your site to be secure, you need a certificate on your server. If not, you may as well have an HTTP site.

Fantastic! Make sure your SSL/TLS mode is set to Full (strict) once you have the certificate and you should be good to go.

@domjh sorry bro, im little bit stupid and have bad english :smiley:
problem solved just by turning settings to flexible from full encryption. Why it was setted to full? - i dont know :smiley:

@domjh sorry for your time, and thank you for patience!!