Http > https

ssl
autohttps

#1

Hello,

I’m having a hard time redirecting sites to HTTPS. At the moment, I need to type HTTPS for my site to work. Typing the site without it won’t redirect and will not load the page. I’ve seen other posts in the forum, but nothing fixes my situation.

I’ve triggered the setting in Cloudflare, but it does not fix it.

My current set up uses Caddy.

Any insight would be much appreciated!


SSL Mismatch Error after HTTP redirect
#2

Make sure you have ‘Always use HTTPS’ enabled under your ‘Crypto’ tab and also make sure the DNS records associated with your site (e.g. www.example.com, example.com) are being proxied by Cloudflare - i.e. have the ORANGE cloud next to them.


#3

@saul , thank you for your reply!

Should I click these clouds:

image|690x230 ?

I was told that this was used for cache purposes. I already have “Always use HTTPS” under the crypto tab.


#4

Yes you need to allow Cloudflare to route your traffic.

Else, it only act as a DNS.


#5

Thanks for the help @edricteo and @saul

I did just that, however that took my website down. The page won’t load anymore.


#6

same here…


#7

Can you start a separate topic with details about your individual issue so that people can review and try to help?


#8

When you use Cloudflare in front of Caddy, you need to use “Full (strict)” SSL in your Cloudflare site settings.

Caddy will redirect HTTP->HTTPS by default when automatic HTTPS is used (which is, of course, the default).


#9

A post was split to a new topic: Unexpected 502 errors, but server is up