Http header error "500 Internal Server Error"

Never face this before.
Anyone here get this Error:

< HTTP/2 500 Internal Server Error
< date: Sat, 21 Nov 2020 14:45:09 GMT
< content-type: text/html; charset=UTF-8
< x-frame-options: SAMEORIGIN
< cache-control: private, max-age=0, no-store, no-cache, must-revalidate, post-check=0, pre-check=0
< expires: Thu, 01 Jan 1970 00:00:01 GMT
< cf-ray: 5f5b315cefa01c97-SJC
< server: cloudflare

HTTP /1.0 or HTTP /1.1 get the same error.
Site hosted on shared hosting and accessable via browser and seem to be online. But whenever i check http header via tool or command, it always reply with “500 Internal Server Error”.
Is it a hosting problem?

5xx errors are caused by the host, as you’ve probably seen here before. Is there anything in your server’s error logs?

To double check…what you’re posting looks to be from curl. If you visit it in the browser, do you get a Cloudflare-branded error page, or is it plain text?

no sir, as i said, user can visit website normaly, no problem. That error just happen when i used some http header tools to check.

You can use a browser to send those same headers. It would still be nice to know if that 500 error comes with a Cloudflare-branded page, or plain text.

You also didn’t say anything about checking your server logs.

If i use browser, there is no error. Page is loading fine.

There is not much, because i’m using shared hosting.

Since this sounds easy to replicate, have you contacted your host to see if they can watch the connection?

Yes, i have just created a ticket. I’m waiting for their reply. It seem a blocked iframe from server, i guess. But want to see if anyone here face this problem before?

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.