Http error 500


#21

I used https://www.whatsmydns.net to get my ip. now I’m done with almost everything. Only 1 thing left, which is the https.

If you go to https version of my website, you will see a broken version of my website. I’m using the flexible ssl.

Any ideas?


#22

@meuo80 it is because of HTML.
Change the whole “http://” to “//” so both http and https will works fine.


#23

where exactly?


#24

It looks like you are using wordpress. Have you changed your address in the wordpress admin to be https:// instead of http:// ?

If not, before you do that, you should install this plugin which will prevent infinite redirect issue with wordpress and Cloudflare’s flexible SSL.


#25

On your website’s code, If you use wordpress or something like this, just change there your website link to https://. Current this is set http://


#26

Guys, you sorted out one of my biggest problems!

Thank you very much Andy for the essential plugin. I’ve been suffering with this for a long time.

Thank you very much Gustavo. I did it and it’s working fine now


#27

Great news! I went to your site https://qallwdall.com and it resolves fine.

However, I think there may be some mixed content that’s not being served via https. You may want to experiment with the Cloudflare ‘Automatic HTTPS Rewrites’ feature that’s at the bottom of the ‘Crypto’ page to see if that resolves the mixed content errors. I inspected with Firefox and it looks like it’s just one image - your logo I think in the upper right, that’s being served via http instead of https.


#28

I fixed that… Thank you!


#29

now since around 6 hours, the website keeps going up and down for no specific reason. I checked the dns settings and they are fine. I doubt the ssl is the reason.


#30

Seems like nothing is wrong with Cloudflare’s infrastructure
https://www.cloudflarestatus.com/


#31

so what might be the issue? The full loading time increase from 2.5 secs to 8 secs.


#32

I’m not sure what the specific issue could be, but your site could use some performance optimizations at some point. I ran some tests from California and your site loads in ~15-20 seconds.

I used GTmetrix, Pingdom and WebPagetest from various locations on your site. You seem to have a lot of external resources which are adding to the overall load time. I can help you troubleshoot a bit more later but check out the performance and see if there’s anything obvious that stands out. During my tests your site wasn’t ‘down’ at all, just loading a bit slow.


#33

I really don’t know what happened. As you see, it happened at 8 am while I was asleep. Nothing happened before or after 6 hours.

It’s really weird.


#34

I had same trouble. I fixed. Thanks for responses. :relaxed: