HTTP 500 error for image in Pages site

I’m a little new to pages but have come across an unusual error for a static image in my Hugo site.

In particular I have an image that returns a HTTP 500 error, while nothing else has this issue.

The URL for the image is here:

spwelectrical.com

The original image opens fine locally and via a browser using the development server built into Hugo.

I have purged the cache for the domain, renamed the image locally, recreated the image (ie its just a resized version of another image on the site, which works fine).

Any hints on where to look?

5 Likes

Currently seeing the same issue (was not an issue before) on a single path.

Here’s a live example: https://fc066ce7.savjee-be.pages.dev/2021/04/max17043-battery-monitoring-done-right-arduino-esp32/

The page can’t load any JPG or PNG images from this path:

https://fc066ce7.savjee-be.pages.dev/uploads/2021-04-28-max17043-battery-monitoring-done-right-arduino-esp32/

Weirdly enough, there is an SVG image in this path that does load correctly.

Response headers from Cloudflare Pages:

alt-svc: h3-27=":443"; ma=86400, h3-28=":443"; ma=86400, h3-29=":443"; ma=86400
cf-ray: 64770761eafb2d07-LHR
cf-request-id: 09be42f13100002d07c5afd000000001
content-length: 0
date: Thu, 29 Apr 2021 08:06:03 GMT
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
nel: {"report_to":"cf-nel","max_age":604800}
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report?s=yZr5HEGRk%2FKIToRwJj6il7evdghE3evchf5%2Bs70eH8BzXtTWBOpLb3VI7XZ4VOfBCAOdbKDgyo7umT3%2BqqCO8xXfCGP4I1UA6wgJeTuvCIPc6IwqYz0w32BbfL3q"}],"group":"cf-nel","max_age":604800}
server: cloudflare
vary: Accept-Encoding

The behaviour I’m seeing is similar but so far all other images are fine…even others in that directory.

I might retest adding a couple more images to see the results which might show it’s only “new” images since a certain time.

But you would have expect this to affect new builds of the site…not just (in my case) one image.

Similar issue at https://stepcoop.org/team/ hosted on step.pages.dev, Images listed on the page gives 500. I tried redeploying, changing location, name, image etc didn’t worked. One small thing an older image I have removed still shows up in public even after purging cache.

Same here, I’m using jekyll for the website.

Same here!

Likewise, 500s on most PNG images. Noticed yesterday. Using zola. Tried purging cache, enabling Developer mode, and removing optimizations without success.

Hey sorry about this, I’m from Workers/Pages team. We identified an issue with image compression, and it has since been resolved. To fix, please kick off a new deploy:

$ git commit --allow-empty -m “Trigger notification”

^git command for an empty commit

4 Likes

Thanks! Solved!

Yep! Fixed it for me, too.

Thank you!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.