HTTP/3 (QUIC) not detectable in Chrome Canary with --enable-quic --quic-version=h3-23

Cloudflare activated HTTP/3 (QUIC) on one of my domains.

I have enabled HTTP/3 (QUIC) for the domain

Downloaded Chrome Canary browser for Win 10 64 bit.

Added the following in the target field (by accessing Chrome Canary.exe properties)
“C:\Users\Name\AppData\Local\Google\Chrome SxS\Application\chrome.exe” --enable-quic --quic-version=h3-23

Enabled the support for HTTP/3 (QUIC) in Chrome://flags/

Visited the website and looked at the developer tools > network tap > protocol > it is mostly h2 or http/1.1 for all resources except Google resources which are http/2+quic/46

Tried for https://blog.cloudflare.com/ too and no luck.

No http/2+quic/46, only h2 or http/1.1

see https://blog.cloudflare.com/http3-the-past-present-and-future/

Note that due to how HTTP/3 is negotiated between the browser and the server, HTTP/3 might not be used for the first few connections to the domain, so you should try to reload the page a few times.

Actually I reloaded over 50 times.

i didn’t have to do that step for it to work, so maybe reverse that

Wasn’t able to get it on Cloudflare.com, but got it on my own https://judge.sh first try (but not on the first request due to how H3 negotiates itself as said above)

Yeah, I have set it to ‘default’ but still the same result. I’m wondering why.

Try canary browser with http/3 flags enabled --enable-quic --quic-version=h3-23 on other cloudflare http/3 enabled sites to verify it isn’t a problem with your browser/pc

The browser doesn’t seem to show http/2+quic/46 for all the websites listed above.

Both in Incognito mode and normal mode of Chrome Canary

(with “C:\Users\Name\AppData\Local\Google\Chrome SxS\Application\chrome.exe” --enable-quic --quic-version=h3-23) on target field of Chrome Canary.exe properties.

yeah could be Chrome canary related as it’s still experimental and needs development over time

custom built curl with HTTP/3 support verifies HTTP/3 h3-23 draft though

curl-http3 --http3 -4Iv https://cloudflare-quic.com
*   Trying 104.20.106.50:443...
* Sent QUIC client Initial, ALPN: h3-23
* h3 [:method: HEAD]
* h3 [:path: /]
* h3 [:scheme: https]
* h3 [:authority: cloudflare-quic.com]
* h3 [user-agent: curl/7.67.0-DEV]
* h3 [accept: */*]
* Using HTTP/3 Stream ID: 0 (easy handle 0x55ee8a4a1e60)
> HEAD / HTTP/3
> Host: cloudflare-quic.com
> user-agent: curl/7.67.0-DEV
> accept: */*
> 
< HTTP/3 200
HTTP/3 200
< date: Sat, 28 Sep 2019 11:31:03 GMT
date: Sat, 28 Sep 2019 11:31:03 GMT
< content-type: text/html
content-type: text/html
< content-length: 106072
content-length: 106072
* Added cookie __cfduid="d079b09c43b049741d413eec8c12cea2e1569670263" for domain cloudflare-quic.com, path /, expire 1601206263
< set-cookie: __cfduid=d079b09c43b049741d413eec8c12cea2e1569670263; expires=Sun, 27-Sep-20 11:31:03 GMT; path=/; domain=.cloudflare-quic.com; HttpOnly; Secure
set-cookie: __cfduid=d079b09c43b049741d413eec8c12cea2e1569670263; expires=Sun, 27-Sep-20 11:31:03 GMT; path=/; domain=.cloudflare-quic.com; HttpOnly; Secure
< alt-svc: h3-23=":443"; ma=86400
alt-svc: h3-23=":443"; ma=86400
< expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
< server: cloudflare
server: cloudflare
< cf-ray: 51d5638c0cf2c5e4-EWR
cf-ray: 51d5638c0cf2c5e4-EWR
* Connection #0 to host cloudflare-quic.com left intact

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.