HTTP/2 protocol is not supported

No matter what I change I just can’t get my server to deliver data using http2, the domain is imageees[dot]com

Thank you so much to anyone who would spend a second of their time helping me out of this

Welcome to the Cloudflare Community!

Your web server is not proxied :orange: by Cloudflare, meaning visitors are connecting to it directly. If you enable proxy :orange: by editing the record in the DNS → Records panel, click “Edit” and then the toggle next to DNS Only :grey: to make it proxied :orange:, Cloudflare would sit in front of requests to your site, then you can enable HTTP/2 and HTTP/3 under Speed → Optimization → Protocol Optimization (Magic link: https://dash.cloudflare.com/?to=/:account/:zone/speed/optimization/protocol).
(You would also benefit from Cloudflare’s DDoS protection, free WAF, Cache, and other enhancements)

Connections to your website would then be: Visitor (http/3, http/2, http/1.1) → Cloudflare (if not cached, http/1.1) → Origin. A lot of the benefits of http/2 and http/3 can be acheived with just the Visitor → Cloudflare connection using it.

If you do not want to enable proxy on your site, or if you want connections from Cloudflare to your origin web server to use HTTP/2 as well, then you can enable http/2 to origin under Protocol Optimization, and enable http/2 support in your Apache configuration, it looks like your version (leaked by Server header) supports it.

https://httpd.apache.org/docs/2.4/howto/http2.html

3 Likes

It’s crazy I didn’t think about myself you helped a lot !

I’ll tell this to chat got !

Many thank’s!

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.