HTTP/2 greyed out

The HTTP/2 setting is greyed out under Network in he dashboard.

Is it not possible to enable this with a free account?

1 Like

Mine is greyed out on the free plan but with the toggle set to “on”. cc @cloonan

1 Like

Can you post a screenshot of it?

Also, you can test HTTP/2 on your website:
https://http2.pro

That’s what mine looks like, too. I wonder what the OP’s looks like.

Hi @VDM, once you try the site @sdayman mentioned, let us know if you see HTTP/2. You can also try curl -svo /dev/null https://example.com to see if you get < HTTP/2 200 in the reply. The best suggestion I’ve seen is to try via the API, https://api.cloudflare.com/#zone-settings-change-http2-setting. HTTP/2 is enabled for all zones but not available to disable via the UI on some zones (I cannot on my free zone, but can on business and enterprise).

1 Like

Ok, well this is rather embarressing. Checking my dashboard now, it’s showing ‘On’ and greyed out. I must have misread it earlier. Sorry to waste your time. I appreciate the quick responses. Please ignore me. I think I need more sleep. :sleeping:

5 Likes

Adding a reference link to a capability by plan table, https://support.cloudflare.com/hc/en-us/articles/214534308-Can-I-disable-HTTP-2-for-my-website-.

1 Like