HTTP/2 Enabled but Not Working

We have enabled http/2 on our webserver and in Cloudflare.

However, testing services ( https://tools.keycdn.com/http2-test & https://http2.pro/ ) say that we have not enabled it fo our site.

How can I diagnose/fix this issue?

I am no expert; any guidance is gratefully appreciated. Thank you.

What’s the domain?

https://www.gthankyou.com

gThankYou Logo Sept2008-Small.jpg

I can confirm it’s using 1.1 instead of HTTP/2
If you’re on a paid plan, see if you can use the API to turn it off, then back on:
https://api.cloudflare.com/#zone-settings-change-http2-setting

If that doesn’t work, or you’re on a free plan, contact Support:
Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button.

Yes, I have a paid plan for this URL.

I’ll try the API.

Rick

1 Like

Geez, I didn’t even look at my Paid Plan setting. It has a regular toggle in the Network settings tab (my free plans have it greyed out). Did you try turning it off and back on?

I didn’t. I’ll do that shortly. How long did you suggest it be off?

gThankYou Logo Sept2008-Small.jpg

Since it’s been broken for awhile, you’re probably not in a huge hurry. Give it 5 minutes before switching back.

Thank you.

gThankYou Logo Sept2008-Small.jpg

Thank you for the help with this. I sincerely appreciate the guidance.

I turned http/2 support off/on in Cloudflare, then retested.

Our main subdomain, www, still appears unsupported.
However, our other two subdomains, more. and info., are hosted elsewhere and are supported. So, I think it’s a problem with our hosting service/server and/or the devs managing that for us.

Rick

I think what your host uses, and what Cloudflare uses, are independent. In fact, I’m pretty sure Cloudflare connects to origin servers using 1.1.

I think it would be a good idea for you to open a Support Ticket to have them look at it:
Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button.

1 Like

Thank you.

gThankYou Logo Sept2008-Small.jpg

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.