HTML5 & Websocket Connections Blocked & Cloudflare

I have 3 kids in college using Blackboard Collaborate and they have been having varying levels of difficulty of getting in and connecting to classes. Eventually the error comes back as:

Upon attempting to join a Collaborate Ultra session from a school or office network, the session fails to connect and the user encounters one of the following error messages: Failure Code J10

I checked their laptop security and couldn’t find any restrictions and then checked out my network firewall and couldn’t find any issues either.

When I changed the DNS settings from Cloudflare to another provider, the problem fixed itself. Is there a solution to this or do I have to stop using

This is B.S. After 8 days no one from support can take a moment to respond? I get the community doesn’t always know what to do but support should be monitoring what’s going on.

HTML5 - Websockets - Collaborate - Doesn’t work - College Classes - Can’t attend online during lockdown!!!


When you were using did the connection to school blackboard collaborate always fails or sometimes work and sometimes fails?

After changing DNS settings there wasn’t a single occurrence of the problem?

Did you tried to configure again and check if the “Failure Code J10” returns?

It would always eventually fail but it seemed to try to load and make the connection but ultimately the connection would fail and we would get the J10 Failure code. Once exhausted everything else, checking the laptop, security software then checking the network and my firewall, I changed the DNS as a last resort and it worked. I tried a couple of other DNS services without issue but the minute I went back to, it would fail again.

I’m using, registered in blackboard trial website but unfortunately it isn’t exactly the same scenario as your kids had as there are no contents or video lessons.

What i find strange is that we have been using other learning / meeting services here at home, similar to this and hopefully without any issue so far or that we have detected.

Anyway based in your description it really seems an issue, maybe its just impacting some data centers.
What you could do is to share your ticket number here and one of the moderators might try to push support team.

We are not living normal days, so i understand all kind of delays.
Online school for most of teachers and also parents its not being easy, we were not prepared for it :slight_smile: but we will adapt to it one day at a time.

stay safe

The other variable is the school’s network. In my case it’s UMass Boston. We access the Collaborate sessions through a UMass website which then connects into the Collaborate website.

I’d love to open a ticket or get the attention of a moderator to get the support teams attention. Just not sure how to do that. When I click on support all I get is the community and no way to open a ticket.

I thought you already opened a ticket and no one replied you, so in your second post you were referring to the community post and not an official ticket.

As mentioned earlier i’m using and from user point of view tested two blackboard products:

  • Blackboard Learn
  • Black board collaborate with the ultra experience

I’ve “collaborated” during 1h without any issue, tomorrow i can try to add more people in the call, but for the moment i conclude this is not a general issue and is somehow related to your area.
The trial is done by sharing two links, one for participants and other for moderator and when starting the session i was connected to an amazon server based in USA.

Troubleshooting tips that i found, but i think you already went through this:

To raise a ticket to support, its recommended to retrieve some data first mentioned in this post and when problem is present:

To create a ticket:

Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button.